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About the Q1 2017 Release 
e-Builder quarterly releases include improvements to a targeted area of the product and usability 

enhancements that increase the ease-of-use of current features and functions across the entire product. 

The latter is a culmination of user feedback and requests. In addition to enhancements, a list of resolved 

cases for the month is also enclosed.  

Your Opinion Matters 
We rely on your feedback to better serve you. If you have ideas about improving our product or service, 

please don’t hesitate to let us know. Below are four ways to reach us.  

 

 Like/Dislike  – Located in the banner of e-Builder Enterprise™ are like and dislike 

buttons. Click these to express your opinion of a particular page. This feedback is used to help 

prioritize upcoming product enhancements. 

 e-Builder Community – The Ideas section of the e-Builder Community gives you a platform to 

share your thoughts on how to make e-Builder better. You can read and vote on the ideas of 

fellow e-Builder users or post your own. Those with the highest vote totals are noted when 

forming e-Builder’s roadmap. To access the Community, click the arrow next to your username 

within the banner of e-Builder Enterprise, and then click eB Community.  

 
 Support – Our Support staff is always available to meet your needs. To speak to a live customer 

service representative, call us within the U.S. at 888-288-5717 and outside of the U.S. at 800-

580-9322, or email us at support@e-builder.net.  

 Annual Technology and User Conference – The annual e-Builder Technology and User 

Conference offers a unique and up-close opportunity to gain insight into e-Builder product 

direction, learn best practices from industry professionals and peers, and to exchange 

information and ideas with members of the e-Builder community.  

  

mailto:support@e-builder.net
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What’s included in this Document 
 A description of each product enhancement 

 Guide Me retirement notice 

 List of resolved cases, including new steps for adding photos to BI reports 

Note: The release is scheduled to be completed between the hours of 10pm EDT and midnight which will 

not impact system availability. 

Release Note Change Log  
The release note change log includes all changes made to this version of the Release Notes document. 

Date Version Number Description 

March 7, 2017 1.0 Initial release 

March 16, 2017 1.1 Includes resolved cases 

 

Summary of Features and Impact to Users 

Feature Immediately Available 
 No setup required 

Setup Required 

   

 Bulk Edit Project Fields 
 

  

 Bid Scope Import – Map to Budget Line 

Item 

  

 Expanded Support for Drag and Drop File 

Upload 

- Bid Submission 

- Forms 

  

 Product Ideas Portal   
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Product Enhancements 

Bulk Edit Project Fields 

Making updates to project fields across many projects is now vastly more efficient.  When you have a lot 

of updates to make, such as changing the Status or Target Date for multiple projects, it can be done at 

once in a bulk action.  For example, update a custom field across 50 projects from the Project Details 

page with just a few clicks.  The Bulk Edit capability is accessible anyplace you can edit projects.  

Bulk Edit applies to updates of Project fields and Custom fields. 

Permissions considerations:  to perform Bulk Edits the user must have permission to update the field.  

The following permissions are validated: 

 Add/edit project  

 Custom field permissions 

Upper Limits:  Bulk Update enables updates across up to 50 projects for up to 25 fields at a time 

 

 

Real World Scenario – Project Status Meeting Requires High Volume Updates 

New information in a project status meeting require 50 projects to have their Status and Phase values 

updated in e-Builder.  Rather than updating each project separately, which would take 4 clicks per 

project and potentially take more than an hour.  With Bulk Edit, all 50 projects may be selected at once 

and the update take a matter of minutes. 

 

Applying Bulk Edit  

1. Access Bulk Edit from Administration Tools > Projects >  Manage Projects, or by clicking the 

Projects tab to access the Projects page, or My Settings > Membership  > Projects 

2. Select the Projects to be updated by clicking the checkbox next to the project and click the Bulk 

Edit button.  Note you may select up to 50 projects at a time. 

3. Select the Fields to be updated utilizing the Available fields filter or typing the name of the field 

in the input box 
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4. Update the value of each field individually if the values are different or click Apply to All if the 

same field value applies across projects. 

5. Click Save.  A confirmation message will appear when updates are successful or a warning if one 

of the entries is invalid. 

 

Bid Scope Import – Map to Budget Line Item 

Did you know that Bid Scope items can be mapped to budget line items and commitments created from 

the awarded bid?  It’s called the Bid Award to Commitment process and it makes it easy to integrate 

Bids with the Cost module.   Now that process is even more streamlined with the addition of budget line 

items to the Bid Scope Import. 

Now you can associate bid scope items with budget line items from the beginning of the process, when 

importing the bid scope.  When the commitment is generated from the awarded bid, the association 

between bid scope item and budget line item will already be in place. 

 

 

Real World Scenario – High Volume of Bids 

With 10 new projects approved and procurement engaged, a Bid Manager must create 10-plus bid 

packages in a compressed time period.  To make the Bid Package creation and downstream award and 

commitment creation process as efficient as possible for the team, the Bid Manager imports the Bid 

Scope.  As part of the Import a budget line item is associated with each bid scope item so that the 

budget line item is carried through automatically to the awarded commitment.  Making the association 

up front can potentially save hundreds of clicks making this association manually later.  

 

Setup 

To set up the Bid Award to Commitment feature: 

1. Bidding integration must be enabled within the cost module.  This is already enabled in the e-

Builder Beta account or your review purposes.  To enable for your account contact  e-Builder 

support (by toggling on the attribute cmEnableBidding for the account). 

2. In e-Builder Administration tools turn on the Bid Award to Commitment feature.  Select 

Administration Tools > Bidding  > Options and choose the desired process in the Bid Award to 
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Commitment field.  You may also allow this setting to be changes on individual bid packages by 

clicking the checkbox. 

 

 

Apply Bid Scope Import – Map to Budget Line Item in a Bid Package 

1. Select Bidding > Select the Desired Project 

2. Select the desired package and select the Bid Scope Tab 

3. Select Import Bid Scope 

 

 

 

4. Select Add New Bid Items or the update or overwrite existing items option depending on your 

business need 

5. Select Download Import Template 

 

 

 

6. Populate the Budget Line Item field for each desired Bid Scope Item 
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7. Save and Import the file 

 

 

8. When the Bid is Awarded and a Commitment Process is created through the Bid Award to 

Commitment Process, the Budget Line Item will be populated with the values populated in the import 

for each Bid Scope Item 
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Expanded Drag and Drop – Forms 

We’ve heard and acted upon feedback to further expand the use of file drag and drop to make 

document upload more efficient.  Now Forms file fields and Bid Submission are added to the many areas 

where drag and drop is supported.   

 When multiple File Fields exist on a Form, it requires users to upload files to each File Field manually, 

which can be inefficient.   In order to improve productivity, e-Builder added the ability to drag and drop 

files directly to a Form Field. In addition, this enhancement includes streamlining and reducing the 

number of clicks to complete a file upload. 

This feature applies to: 

 Forms, Add comment from public page - this page is displayed when requesting an external 

comment on a form.  Enables drag and drop of files directly into the supporting documentation 

grid. 

 Forms, File Fields -  Enables drag and drop of files directly into the supporting documentation 

grid. 

 

 

 

 

Real World Scenario – Contractor Required Documentation  

An owner may require supporting documentation for Change Directives or other items that are tracked 

through a Form.  On a large project, Contractors may be updating supporting documentation frequently.  

With drag and drop now supported, contractors and other form contributors save clicks and time. 

 

Setup, Forms File Field 

1. Select Setup > Administration Tools > Forms > Manage Form Types 

2. Edit a Form Type > Select Edit Fields 

3. Click Add Field > Select the File Data Type  

4. Follow Data Field wizard > Click Save 

Fill out Form 

1. Navigate to Projects > Select a Project 

2. Select Forms > Fill Out Form > Select a Form with File Fields 

3. Navigate to the File Field 

4. Drag & drop a File into the File Field > Then the Upload Modal will open 



  

© Copyright 2017, e-Builder, Inc.   Page 10 of 17   Q1 2017 Release Notes 

5. Add the file description > Select a Folder > Update the File Custom Fields 

6. Click Upload 

 

 

 

 

Expanded Drag and Drop – Bid Submission 

Document drag and drop is also expanded to make the bid submission process easier for invited bidders 

that are Submitting bids. 

This feature applies to: 

 Bid Submission, File fields – located on Bid Submission Custom fields tab.  Enables drag and drop 

directly into file fields.   

 Bid Submission, Supporting Documentation - Enables drag and drop of files directly into the 

supporting documentation grid. 

 Bid Submission, Submit Quote page -  Enables drag and drop of files directly into the Upload Bid 

Submission field 

Setup - Bid Submission File Fields, Supporting Documentation 

1. Select Bidding > Choose a Project > Add Bid Package 

2. Fill out all required fields 

3. Select Supporting Documentation Required 

4. Add Bid Submission Custom Fields that are File Fields 

5. Save Bid Package 

6. Add Bid Scope 

7. Invite Bidders 
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Bid Submission 

 

1. Invited bidders may access the Bid Package by clicking the link in the Invitation Bid email and 

entering their Invitation Key 

 

 

2. On the Bid Submission tab, scroll to the Supporting Documentation Tab.  Drag and drop is 

enabled. 

 

 

 

3. Select the Custom Fields tab.  Drag and drop is enabled for File Fields. 

 

4. Submit quote – Access an open bid as an Invitee and click the Submit quote button.  The Upload 

Bid Submission field accommodates direct drag and drop of files. 
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Product Ideas Portal 
Have a product idea to share?  A way to make your job easier or e-Builder easier to use?  Now there’s a 

new more robust way to submit product ideas.   The Product Ideas portal makes it easy to submit an 

idea, view the ideas of your colleagues, and even vote on the ideas you think have the most benefit.   

 To access the Idea Portal, click your profile username and select the Product Ideas link.  Then 

click “Add Idea”.   We’re listening! 
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Appendix A – Guide Me Retirement 

With the Q1 Release, Guide Me will no longer be available and clients are encouraged to utilize Online 

Help and Resources in the Community for training material.   

Why are we retiring this feature? 

Removal of the Guide Me service is part of our effort to follow best practices for online training and 

assistance.  The decision was informed by analysis of product usage information, listening to feedback 

shared via the Product Ideas portal , and conversations with customers.  

 

What action do I need to take? 

No action is required by administrators or end users to accommodate this change. 
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Resolved Cases  
The following is a list of resolved cases for the month of August. If you have any questions regarding this 

maintenance release, please contact e-Builder Support at 888-288-5717 or via email at support@e-

builder.net.  

 

 

 

 

 

 

 

 

Business 

Intelligence 
Case Number: 00204564 

ERROR WHEN RUNNING A BI PROCESS REPORT 

When running a Standard BI report with Process Summary data the Date Due column generated 

an error. The issue is corrected so there will not be an error while running the BI report. 

 

Case Number: 00198593 

PHOTO ERROR ON BI REPORT OUTPUT 

Reports with progress photos were failing when exporting to PDF. After a data and code fix, now 

reports can be exported to any format and the images are shown correctly.  

There has been a change of steps for adding progress photos to a report, as follows: 

 

 

 

Case Number: 00182265 

 

BI REPORT TIME STAMP SHOWS INCORRECT TIME ZONE STAMPING 

All BI reports were running using the server time zone. Now BI reports are executed using the 

current user time zone. 

 

Module Number of Resolved Cases 

Business Intelligence 3 

Calendar 1 

Cost 3 

Documents 1 

Processes 5 

Schedules 1 

Submittals 1 

Time Tracking 2 

1 - Select the cell and click in the Formula Editor 

2 - Select Load Image in Other and click Add 

3 - Select the Image field from left panel and click Add and then OK 

 

mailto:support@e-builder.net
mailto:support@e-builder.net
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Calendar 
Case Number: 00209383 

ERROR WHEN ADDING EXTERNAL USER 

Adding an external attendee to an event caused the current attendees of the event to be 

deleted. Now the external attendee can be added without deleting the current attendees. 

 

Cost 
Case Number: 00206210 

BUDGET AMOUNT ON FORECAST SCREEN DOUBLE ACTUAL VALUE 

Cost Summary Snapshot values were generating doubled values in Forecasts. Now the forecasts 

can be created without doubled values. 

 

Case Number: 00204013 

EXCEPTION: "INVALID PROJECT COMPANY NAME" 

Performing cost imports that mapped a value to a company on project custom field might fail if 

the company was included in multiple projects.  Now, assigning a value to a company on project 

custom field during an import will correctly identify the project and not error. 

 

Case Number: 0020083 

STATUS IN COST MODULE NOT UPDATING 

There was an issue with the total amounts not being calculated correctly. A data fix was 

completed to address the issue. 

 

Documents 
Case Number: 00203863   

ERROR MESSAGE WHEN DRAGGING MULTIPLE FILES FOR UPLOAD 

 An error displayed in some instances depending o how the file was saved and formatted.  This 

case has been identified and accounted for so files will no longer have issues uploading.  

 

Processes 
Case Number: 00210937 

ERROR USING STAMP 
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Previously, clicking on 'Save as New document' after dragging the stamp onto the document 

caused the page to render a blank document without any content.  Now the issue is addressed 

so that the document is properly displayed and the stamps are saved without issue. 

 

Case Number: 00200242 

INTEGRATION IMPORT PERIODICALLY FAILS 

When importing invoices, if any trigger a workflow exception for invalid status or cost violation, 

the system displayed a generic error with no relevant info on it.  Now, if this occurs the system 

shows more detailed and relevant error text. 

Case Number: 00205559 

MASTER COMMITMENT CHANGE GLOBAL CUSTOM FIELDS BEING CLEARED 

When a process moves from one step to another, in some instances master commitment 

change custom fields were not properly saved. The issue is addressed and the information is 

properly saved. 

Case Number: 00204186 

DATA ASSIGNMENTS INCLUDING EXTRA STRING VALUES IN THE ASSIGNMENT 

When an assignment expression consisted of either dropdown or multi-picklist data field values 

a validation error was returned upon saving the expression. Now the issue is addressed and 

saving the expression functions as expected. 

Case Number: 00204004 

GENERAL INVOICE IMPORT ISSUE 

Importing general invoices via the Data Entry page could fail in some instances and the e-Builder 

error page would be displayed. Now, the import functions as expected. 

 

Schedule 
Case Number: 00209134 

ALLOWED DATE RANGES EXPANDED 

There was a restriction on the dates allowed for calendar entry where the oldest year was 

restricted to 1980.  This has been expanded to allow dates back to 1900 to accommodate 

historical data. 

Submittals 
Case Number: 00209097 

ERROR IN VERSION SEQUENCE NUMBERS  

Previously there were issues where revision numbers may have been skipped.  This issue has 

been corrected. 
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Time Tracking 
Case Number:  00206074 

DUPLICATE TIMESHEET 

Timesheets submitted appeared to be submitted twice, but once approved showed up only as 

one.  This issue has been corrected. 

Case Number: 00209115 

RANDOM TIMESHEET ERROR RELATED TO SAVE 

There was an issue upon save when editing timesheet rows in certain instances.  The issue has 

been corrected.  

 

 

 

 

 


