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About the Q4 2016 Release 
e-Builder quarterly releases include improvements to a targeted area of the product and usability 

enhancements that increase the ease-of-use of current features and functions across the entire product. 

The latter is a culmination of user feedback and requests. In addition to enhancements, a list of resolved 

cases for the month is also enclosed.  

Your Opinion Matters 
We rely on your feedback to better serve you. If you have ideas about improving our product or service, 

please don’t hesitate to let us know. Below are four ways to reach us.  

 

 Like/Dislike  – Located in the banner of e-Builder Enterprise™ are like and dislike 

buttons. Click these to express your opinion of a particular page. This feedback is used to help 

prioritize upcoming product enhancements. 

 e-Builder Community – The Ideas section of the e-Builder Community gives you a platform to 

share your thoughts on how to make e-Builder better. You can read and vote on the ideas of 

fellow e-Builder users or post your own. Those with the highest vote totals are noted when 

forming e-Builder’s roadmap. To access the Community, click the arrow next to your username 

within the banner of e-Builder Enterprise, and then click eB Community.  

 
 Support – Our Support staff is always available to meet your needs. To speak to a live customer 

service representative, call us within the U.S. at 888-288-5717 and outside of the U.S. at 800-

580-9322, or email us at support@e-builder.net.  

 Annual Technology and User Conference – The annual e-Builder Technology and User 

Conference offers a unique and up-close opportunity to gain insight into e-Builder product 

direction, learn best practices from industry professionals and peers, and to exchange 

information and ideas with members of the e-Builder community.  

  

mailto:support@e-builder.net
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What’s included in this Document 

 A description of each product enhancement 

 Appendix of Redline Tool feature updates 

 A list of resolved issues 

Note: The release is scheduled to be completed between the hours of 10pm EDT and midnight which will 

not impact system availability. 

Release Note Change Log  
The release note change log includes all changes made to this version of the Release Notes document. 

Date Version Number Description 

November 28, 2016 1.0 Initial release 

December 15, 2016 1.1 Added resolved issues 

Summary of Features and Impact to Users 

Feature Immediately Available 
 No setup required 

Setup Required 

   

 Groups 
 

  

 Process file field upload   

 Copy file options   

 Hide Funding on Process Layout   

 Display timestamp for Submittal 

Comments 
  

 Lock Bid Tabulation Export   

 Redline Tool Update   

 Funding Transaction Custom fields   

 Edit Documents in Place: Support for 

Macro enabled files 
  

 Commitment Custom Fields: Data 

Assignments  

  

 Interface Improvements   

 Product Ideas Portal   
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Product Enhancements 

Groups 

Create a distribution list of users and contacts.   Save time when you are cc’ing the same recipients over 

and over on messages and better ensure the right people are kept informed on project activities.  Note 

all users may create a Group, admins have an additional ability to make a group available to all users or 

available on a particular project. 

 Any user can create a group that only they can see 

  Admins can make a Group available to all users, and to one or all projects 

 Groups may be applied in the areas below: 

 

 

 

Message Type Area 

Submittals, Send to Contractor cc External users  

Submittals, Forward for Review cc External Users 

Submittals, Send for Review cc External Users 

Submittals, Forward Submittal Item Send To of Enter External User, cc External 

Users 

Documents cc: box of Send File(s), and Email URL 

messages 
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Projects cc box of Email Users 

Calendar Add Attendee on Event Details page 

Reports Send Reports 

Processes Request Comment, Process Instance 

Forms Send Meeting Minutes 

Schedule Add External Users on Send Schedule 

Mange Users Send Email cc 

 

Process File Upload 

We’ve introduced a new ability to drag and drop files directly to a File Field.  Save time when uploading 

multiple file fields exist in a process.  This enhancement also streamlines and reduces the number of 

clicks needed to complete a file upload. 

 

 Add a File Data field in a process and drag and drop will automatically be available 

 Custom fields are now located in their own tab, simplifying the user experience 
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Documents: Copy File Options 

There is new flexibility when copying files.  When a file with the same name exists in the folder you are 

copying to, you may either keep both copies but rename the latest or apply as a new version. 

 No setup required on the part of client or services team 

 When destination folder contains file with same name the new options appear 

 

 

Hide Funding 

If you have contractors submitting invoices or other cost processes, we’re providing a new ability to hide 

Funding information from the process layouts they access.    Enables greater privacy and reduced errors 

by restricting the ability to view and manage funding from cost processes like invoices from those who 

have no business need to see or edit it. 
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Display Timestamp for Comments 

More easily determine the order in which comments are made throughout the day with a new 

timestamp for comments.  No setup needed. 

Comment timestamps are now available in the following areas:  

 Schedule – Activity View and Details 

 Submittals – Item Details, Package Details 

 

 

 

 

Lock Bid Tabulation Export 

Enables your organization to lock the bid tabulation spreadsheet upon Export.  Assists in meeting internal 

audit requirements and ensure bid information is not manipulated without an audit trail.   

 Those who receive the spreadsheet will be able to view, but not edit the contents. 
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Redline Tool Update: Document Conversion 

As a follow up to the release of an updated version of the redline tool earlier this year, we’ve migrated 

existing redlines to a new format that works with the updated version of the tool.  As a reminder, the 

updated tool:  

 Works across all supported browsers (IE 11and above, Chrome, Firefox, Safari) 

  No Active X plug in needed  

 Immediately available, no setup required 

Important note:  For more information on the feature differences between the previous version of the 

Redline Tool and the new version, see the Redline Tool Updates - Appendix A of this document. 
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Funding Transaction Custom Fields  

In instances when your organization needs to track detailed information about funding transactions, 

such as funding accounts in external systems, new Account Funding Transaction custom fields are 

available. 

 Track detailed information about funding transactions 

 Add to Funding Adjustments to include details (e.g. source account of added funds) 

 Once setup these fields are available in Funding Source details pages, Budget Change funding 

process, oData and Reports that show each line as a transaction  
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Edit Documents in Place: Support for Macro enabled files 
Now macro-enabled files are supported with the Edit Documents in Place feature.  Excel, Word and 

PowerPoint files of type .xlsm, .pptm and .docm are covered.   Macro enable file types are typically 

leveraged for their advanced automation capabilities.   

 Excel, Word and PowerPoint files of type .xlsm, .pptm and .docm are covered 

 No setup needed 

 

 

Commitment Custom Fields: Data Assignment  

We’re providing a new ability to make commitment custom fields available to other cost processes.  For 

example, if your organization tracks insurance policy dates or other data points at the commitment level, 

you could now make those data elements available to a Commitment Change process through data field 

assignments. 

 Commitment Custom fields are now available to Commitment Change, Invoice, and Dynamic 

processes. 

 Use data field assignments to carry the information your team needs forward and avoid 

duplicate entry 
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Interface Improvements 

We continue to make interface improvements to make e-Builder easier to use.  This release we’ve 

simplified the text in buttons throughout the application to make them easier to read and understand.  

We’ve also streamlined the process for starting invoices, eliminating clicks. 

Button text update 

The updated text states the action associated with clicking the button and eliminates redundant 

verbiage that is repeated in other areas of the page.   For example, we’ve updated button text in the 

below areas, but you’ll see this simplified button text approach in many other areas in e-Builder. 

 Budget Line items - 'Add Line Item' to 'Add' 

 Budget changes - 'Add Change' to 'Add' 

 Notes - ‘Add Note’ to ‘Add’  

 Documents - ‘Attached Documents’ to ‘Attach’  

 Forms – ‘Attach Forms’ to ‘Attach’  

 Processes – ‘Attach Processes’ to Attach  
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Start Invoice - Streamlined 

Extra clicks have been removed from the process for starting an invoice. Now the Add Invoice button 

provides a dropdown choice to let the user select either a Commitment or General Invoice.  Previously 

this selection was made after navigating to another page. 

 

Product Ideas Portal 
Have a product idea to share?  A way to make your job easier or e-Builder easier to use?  Now there’s a 

new more robust way to submit product ideas.   The Product Ideas portal makes it easy to submit an 

idea, view the ideas of your colleagues, and even vote on the ideas you think have the most benefit.   

 To access the Idea Portal, click your profile username and select the Product Ideas link.  Then 

click “Add Idea”.   We’re listening! 
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Appendix A – Redline Tool Feature Updates 

Summary 
An Active X plug-in is no longer required to use the redline tool and the Viewer is now compatible with 

all e-Builder supported browsers, not just Internet Explorer. The interface has an updated look and feel. 

Most of the previously available functions are still available with a few exceptions (See the Discontinued 

and New Features sections). Similar controls in the Top Navigation menu have been collapsed into drop-

down menu and others relocated.  

 

Figure 1: Overview of Redline Interface  
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Most Common Tasks 
Users may be looking for options that they are used to and may need assistance finding them if they’ve 

been relocated.  

 Add New Markup – Now located in Annotate Menu. Choosing this option opens the markup 

toolbar on the left just as before. (see Figure 1).  

 Open Existing – Now located in Annotate Menu.  

 

 Rotate – Replaced by the Rotate icon. Still located in Bottom Navigation toolbar.  

 

 

 Show Layers ( ) – This icon is now only visible for images that have layers and is still located in 

the Bottom Navigation toolbar.   

 

Discontinued Features 
The following features have been discontinued. They are not available in this version of the tool: 

 Arc –The arc tool was located in the Line menu on the Left Nav and it allowed you to create an 

arc shaped line to highlight and annotate.   

  

 Measure –The measure tool was located in the Top Navigation toolbar and it allowed you to 

measure distances between points in a file or drawing.   

 

 Polycloud – This was an option in the Cloud menu located on the Left Nav and it allowed you to 

create a polycloud image to highlight and annotate. 

 

 Publish – The options to publish CSF and JPG are no longer available, but you can still publish to 

PDF & TIF.  

 

Relocated Features 

 Display Monochrome – Note: Feature not supported in browsers 

IE 11, Safari 6 and under. This is no longer its own icon, but is 

now an option in the Background color menu and is still located 

in the Bottom Navigation toolbar. 
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 Redact – This option used to be in the Left Nav., but is now its own menu option in the Top 

Navigation toolbar.  

 

 Zoom (Options) – Moved from the Top Nav. to the Bottom Navigation toolbar. 

 
 

 Bookmarks – Used to be accessible from the Task Pane and is now located in the Left Navigation 

menu after clicking Annotate. 
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New Features 

 Pointer – Is now a drop-down menu that includes Cursor and Region (new).  

 
o Cursor – Allows you to make a screen selection, same as before.  

o Region – New option. Allows you to select a region of text to copy. 

 

 Stamp Tool – This is a new feature added to the Left Navigation menu. 

You can add stamps, signatures and symbols. 

 

 Text –  This is a new menu option located on the Left Nav. that allows 

you to manipulate text contained in the file or drawing (strikeout, strikethrough, highlight, 

underline) 

 

 Bookmark –  This is a new option located in the Left Nav. that allows you to add custom 

bookmarks. These can be reviewed and searched from the Task Pane.  

 

 Changemark –  This used to be a single Changemark icon. 

Additional options have been added (strikethrough, highlight, cloud arrow, checkview). 

 

 Cloud –  A highlight option has been added to this menu.  
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Resolved Cases  
The following is a list of resolved cases for the month of December. If you have any questions regarding 

this maintenance release, please contact e-Builder Support at 888-288-5717 or via email at support@e-

builder.net.  

 

 

Cost 
Case Number: 183100 

Previously when editing a commitment change with additional scope items an error occurred.  Now the 
edit process functions as expected. 
 

Case Number: 194016 

Previously, when creating a new master invoice in received status with all $0 line items, if amounts were 
added to the items later, the "Actuals Received" on the corresponding project commitments would not 
be updated.  This allowed invalid commitment changes against them after funds were already allocated. 
Now, the "Actuals Received" column will be properly updated when the item amounts on the master 
invoice are updated. 
 

Case Number: 199527 

Previously Payapp Imports required clients to calculate "Amount this Period" & "Quantity this Period" 

based on unit cost.   Now the import logic is the same as the user interface and does not require clients 

to calculate "Amount this Period" & "Quantity this Period" based on unit cost. 

Case Number: 201666 

Previously an error existed in the Projected Commitment Calculation.  Now the correct values are 

returned. 

Case Number: 202640 

Previously an error was returned when saving general invoices where the date due was set.  Now the 

invoice will save successfully. 

 

Module 
Number of Resolved 

Cases  

Cost 6 

Forms 1 

Mobile 1 

Processes 8 

Projects 2 

Setup Admin 1 

mailto:support@e-builder.net
mailto:support@e-builder.net
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Case Number: 202718 

Previously when saving general invoices, an error was returned if the setup option was selected to save 

the contact to the project contacts but they weren’t yet a member of the project contacts.  Now the 

invoice will save successfully. 

 

Forms 
Case Number: 185421 

Previously Form Fields were displayed Out of Order in error. Now, the information on the form displays 

correctly. 

 

Mobile App 
Case Number: 193131 

Previously forwarding a form in the mobile app would return an error. Now the forwarding is 

successfully completed. 

 

Processes/Workflow 
Case Number: 199363 

 Previously all commitment change processes that were spawned with the Copy Cost Data option 

enabled created new scope items for every item on the parent commitment change regardless if the 

parent commitment change items were linked to existing commitment items.  Now, a setting has been 

added to the Copy Cost Data setting for commitment change processes to allow the functionality to 

maintain the relationship to existing commitment items when spawning the child process. 

Case Number: 182650 

Previously an error was returned when trying to edit a process view.  Now the process view may be 

edited and saved as expected. 

Case Number: 195911 

Previously an error was returned when creating Process Report formulas.  Now the error is resolved. As 

part of the resolution the Activity Description was added to the drop down list in the formula builder. 

Case Number: 198041 

Previously PDF Mail merges that include merge codes to list the time were displaying the time in UTC. 

Now, time merge codes are properly handled to convert the merge code's result to the user's specific 

time zone. 

Case Number: 198600 

Previously an error returned when editing invoice line item quantities.  Now the edit functionality may 

be utilized without error.   
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Case Number: 201418 

Previously when filtering for processes on public list processes page, if the grid was sorted by Process 

Prefix Counter, clicking the Filter button would result in an error. Now, clicking the Filter button in this 

scenario will properly show the results in the grid without error. 

 

Case Number: 202615 

Previously  Dynamic commitment line item processes that had read-only subjects were unable to be 

saved as draft or submitted. Now, dynamic commitment line item processes with read-only subjects are 

working as expected. 

Case Number: 203187 

Previously  when setting the value for a user or company lookup custom field when it didn't previously 

have a value, the save returned an error.  Now the save completes successfully. 

 

Projects 
Case Number: 200416, 00200219 

Previously event handlers with exceptions slowed other event queue items from being processed.  Now, 

any events with exceptions will be automatically retried to improve queue processing. 

 

User Setup 
Case Number: 197375 

Previously, Project Membership and "projects that user is a member of" in the manage membership 

page displayed incorrect data in some instances.  Now the data is returned correctly. 
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Appendix B - Implementation Guide 
This document contains procedural instructions for the implementation and use of the new features 

released in e-Builder’s Q4 2016 Product Release. 

 

 

Groups 
A Distribution List of users and contacts that can be used when cc’ing people on messages in many areas 

of e-Builder (see table below for complete list).  Save time when you are cc’ing the same recipients over 

and over on messages and better ensure the right people are kept informed on project activities.  Note 

all users may create a Group, admins have an additional ability to make a group available to all users or 

available on a particular project. 

 

Setup 

1. Select Contacts > Groups > Add Group 

2. Populate all required fields (Name, Group ID) 

3. Add members to the Group (note that members must be a user or contact to be added to a 

Group) 

4. Admins may make the Group available to all users or themselves only 

5. Admins may make group available to all projects or a particular project 

6. Click Save 
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Apply Group 

1. Navigate to Submittals, and to one of the message types in the below table, for example Send 

for Review 

2. Choose a project > Select Submittals > Submittals Register 

3. Select one or more Packages and click Send for Review 

4. In the CC External Users Box type the name of the desired Group 

5. Select the Group  

6. Click Send for Review 

 

Message Type Area 

Submittals, Send to Contractor cc External users box 
Submittals, Forward for Review cc External Users 

Submittals, Send for Review cc External Users 

Submittals, Forward Submittal Item Send To of Enter External User, cc External 
Users 

Documents cc: box of Send File(s), and Email URL 
messages 

Projects cc box of Email Users 
Calendar Add Attendee on Event Details page 

Reports Send Reports 

Processes Request Comment, Process Instance 
Forms Send Meeting Minutes 

Schedule Add External Users on Send Schedule 

Mange Users Send Email cc 
 

Process File Field Upload 
When multiple File Fields exist on a Process Layout, it requires users to upload files to each File Field 

manually, which has proven to be very time consuming.   In order to improve productivity, e-Builder 

added the ability to drag and drop files directly to a File Field. In addition this enhancement includes 

streamlining and reducing the number of clicks to complete a file upload. 

 

Setup 

1. Select Setup > Administration Tools > Processes > Manage Processes 

2. Start or Edit a Process > Select the Data tab 

3. Click Add Field > Select the File Data Type  

4. Follow Data Field wizard > Click Save 

5. Select Page Layouts tab > Add or Edit Layout 
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6. Add the File Data Field to the Layout > Click Save 

Start/Edit Process 

1. Navigate to the Processes Module > Select a Project 

2. Start or Edit the Process that contains the File Data Field 

3. Navigate to the File Field 

4. Drag & drop a File into the Data Field > Then the Upload Modal will open 

5. Add the file description > Select a Folder > Update the File Custom Fields 

6. Click Upload 

Note: The ability to select a folder and manage custom fields has been added to the File Upload modal in 

this scenario only. The streamlined File Upload approach is on the near-term roadmap, to be added to 

all areas that allow users to upload files. 

 

 

Copy File Options 
When copying files to a folder with an existing file with the same name, a new version of the file was 

automatically created. In some cases, users wanted the ability to append the file to the existing file as 

the next version (essentially, versioning up). To help ensure files are being copied as desired, the 

following options have been added, ‘Copy, but keep both files’ or ‘Copy and append the latest version to 

existing file’. 



 

  

© Copyright 2016, e-Builder, Inc.   Page 25 of 33   Q4 2016 Release Notes 

 

      Copy file(s) 

1. Select the Documents Module > Select a Project 

2. Copy a file to a Folder with an existing file with the same name  

3. Select one of the two Copy Options 

4. Click Continue 

 

Hide Funding on a Process Layout 
If you have contractors submitting invoices or other cost processes, we’re providing a new ability to hide 

Funding information from the process layouts they access.    Enables greater privacy and reduced errors 

by restricting the ability to view and manage funding from cost processes like invoices from those who 

have no business need to see or edit it. 
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Setup 

1. Select Setup > Manage Processes 

Select the process where you wish to hide funding (applies to commitment, general invoice, 

commitment invoice, master commitment and invoices and budget change processes) 

2. Click Page Layouts, select the layout on which you wish to hide funding 

3. Right click on the cost entity in the layout to Edit field properties 

4. Select the “Restrict users from seeing the funding rule per line items" 

5. Click Save 

Important note: hide funding may not be applied to commitment changes against commitments 

with funding  

Start/Edit Process 

1. Navigate to the Processes Module > Select a Project 

2. Start or Edit the Process that contains the hidden funding as the actor you are hiding funding 

from (e.g. contactor on invoice or commitment process) 

3. Populate all required fields for that layout 

4. When adding the Cost Entity, select a line item for the cost entity (e.g. Budget Line Item for the 

Commitment Item) and click Close 

5. Click Add to add the Item 

6. Note that funding information will be hidden from line items and the manage funding button 

will be removed 
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Failed Funding Scenario 

When funding is hidden and funding violations fail, e-Builder allows the invoice or other cost process 

to reach a received status with the failed funding information.  The process actor who is submitting 

the process for approval must fix the funding validations at that point.  Note that the system 

displays a warning when configuring the layout action to mark the status to “Received” status that 

“Funding will not be validated if funding is hidden from the actor layout.” 

 

 

 

Display timestamp for Comments 
e-Builder customers were unable to easily determine the order in which comments were being made 

throughout a given day. To help paint a clear picture and provide an accurate record of when comments 

are left in the Submittal and other modules, e-Builder added a Timestamp to the comment thread.  

 
 

Add Comment Example 

1. Select the Homepage > Select a Project 

2. Select the Submittal Module form the Project Menu > Submittal Register 

3. Click Add Item > Fill out the required fields > Click Save 

4. Click the Comments Tab > Click Add Comment 

5. Add a comment > Click Save 

Comment timestamps are now available in the following areas:  

 Schedule – Activity View and Details 
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 Submittals – Item Details, Package Details 

 Workflow – Start Workflow 

 

Lock Bid Tabulation Export 
Enables your organization to lock the bid tabulation spreadsheet upon Export.  Assists in meeting 

internal audit requirements and ensure bid information is not manipulated without an audit trail.  For 

example, if your organization has a bid review process, you may export the Bid Tabulation spreadsheet 

and send it to internal stakeholders.  To ensure all parties are reviewing the same information you can 

choose to lock the contents of the spreadsheet by configuring the new setting.  Those who receive the 

spreadsheet will be able to view, but not edit the contents. 

 
 

Setup 

1. Select Setup > Bidding > Options 

2. Select the Lock Bid Tabulation Excel Export File” option 

3. Click Save 

Note: this is an account level setting; it may not be enabled/disabled per bid package. 

Export 

1. Select Bidding> Select a Project 

2. Select the Bid Package to be exported 

3. Select the Bid Tabulation tab 

4. Click Export 

Note: the system will export the Excel file as locked with a randomized password 
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Redline Tool Update 
As a follow up to the release of an updated version of the redline tool earlier this year, we’ve migrated 

existing redlines to a new format that works with the updated version of the tool.  The updated tool 

works across all supported browsers (IE 11and above, Chrome, Firefox, Safari).  No Active X plug in 

needed.  New contractors can perform markups without downloading Active X. 

 

Setup 

1. No setup needed, documents will be migrated to the new format automatically 

Documents 

There is no change to how the redline tool or markup files are accessed.  Please note the new 

version of the redline tool does have some new and discontinued features. See Appendix A for 

additional information. 

 

 

Funding Transaction Custom Fields 
In instances when your organization needs to track detailed information about funding transactions, 

such as funding accounts in external systems, new Account Funding Transaction custom fields are 

available.  Once setup these fields are available in Funding Source details pages, Budget Change funding 

process, oData and Reports that show each line as a transaction. 
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Setup 

1. Select Setup > Cost> Custom Fields > Funding Transactions  

2. Click Add 

3. Follow the Wizard Steps 1 through 3 

4. Click Save 

 

Funding Transaction 

      1.   Select a Project 

      2.  Select Funding Sources 

     3.  Click the Name of the desired funding source 

     4. Select Add funds to input a funding transaction 

     5. Funding Transaction Custom fields that have been enabled appear and values may be entered 
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Edit Documents in Place: Support for Macro enabled files 
Now macro-enabled files are supported with the Edit Documents in Place feature.  Excel, Word and 

PowerPoint files of type .xlsm, .pptm and .docm are covered.   Macro enable file types are typically 

leveraged for their advanced automation capabilities.  When viewing options for Documents with these 

extensions, the Edit option shall be available.    The documents will be editable using the locally- 

installed  Excel, Powerpoint or Word application and without the need to check in/check out or upload 

separately. 

 

 

 

 

 

 

Update Commitment Custom Fields from Cost Processes 
We’re providing a new ability to make commitment custom fields available to other cost processes.  For 

example, if your organization tracks insurance policy dates or other data points at the commitment 

level, you could now make those data elements available to a Commitment Change process through 

data field assignments. 

Commitment Custom fields are now available to Commitment Change, Invoice and Dynamic processes. 

Setup 

1. Click Setup 
2. In the left side panel Administration Tools, click option Processes, then click option Manage Processes. 
3. Click the name link for process to implement the assignment in. 
4. Click tab workflows. 
5. Click link for the desired workflow 
6. Click button design workflow. 
7. Load the published workflow. 
8. Right click on start step, then click properties. 



 

  

© Copyright 2016, e-Builder, Inc.   Page 32 of 33   Q4 2016 Release Notes 

9. Click the edit link for the desired action 
10. Click Add Assignment 
11. Note that Commitment Custom fields are available  

 

 

 

 

Interface Improvements: Button Text Simplified 
We continue to make interface improvements to make e-Builder easier to use.  This release we’ve 

simplified the text in buttons throughout the application to make them easier to read and understand.  

We’ve also streamlined the process for starting invoices, eliminating clicks. 

Button Text Update 

The updated text states the action associated with clicking the button and eliminates redundant 

verbiage that is repeated in other areas of the page.   For example, we’ve updated button text in the 

below areas, but you’ll see this simplified button text approach in many other areas in e-Builder. 

 Budget Line items - 'Add Line Item' to 'Add' 

 Budget changes - 'Add Change' to 'Add' 

 Notes - ‘Add Note’ to ‘Add’  

 Documents - ‘Attached Documents’ to ‘Attach’  

 Forms – ‘Attach Forms’ to ‘Attach’  

 Processes – ‘Attach Processes’ to Attach  
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Start Invoice - Streamlined 

Extra clicks have been removed from the process for starting an invoice. Now the Add Invoice button 

provides a dropdown choice to let the user select either a Commitment or General Invoice.  Previously 

this selection was made after navigating to another page. 

 

 


